Bible Pay

Read 2470 times

  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Testnet June 2018 Mandatory Upgrade Testing Thread
« on: June 06, 2018, 09:45:32 pm »
The goal is to test our next mandatory release for quality and stability.

Testnet Instructions:

Git pull origin master to the latest version (1.1.2.6+).
From ~/.biblepaycore
Create a file called biblepaytest.conf
Add the following lines:
testnet=1
server=1
masternodeprivkey=xxx
masternode=0

Launch testnet like this:
cd ~/biblepay/src/qt
./biblepay-qt -conf=biblepaytest.conf

This setup lets you run testnet side by side your prod node or masternode, and allows you to avoid problems finding a separate testnet configuration file.

To set up a hot testnet sanctuary:

Ask a forum member for 500,000 bbp.
Launch the wallet.
Type:  masternode genkey
Copy the key to the 'masternodeprivkey=xxxx' in the biblepaytest.conf file.
Send 500,000 bbp to one of your own receiving addresses.

Restart the wallet.


Testing objectives:

- Ensure monthly (weekly in testnet) superblock is capable of paying a dispursement, ensure getgovernanceinfo is correct
- Ensure daily PODC superblock is also capable of dispursing, ensure exec getboincinfo podc budget is correct
 (The above two tests verify the cascading superblock bug will be mitigated)
- Ensure wallet boots without memorizing prayers on the primary thread, but yet in the background thread (this is the speedy bootup feature)
- Ensure active proposal list view is available (Bhavani)
- Ensure active proposal list vote works (Bhavani)
- Ensure active proposal list pie chart works (Bhavani)
- Test new PODC mature consensus feature (Rob will explain)
   (  // Mature means we stake a point in history (one timestamp per day) as Yesterdays point, and mature means it is older than that historical point.
      // This should theoretically allow the sancs to come to a more perfect consensus each day for PODC elements: DCCs (Distinct CPIDs), UTXOWeights (UTXO Stake Amounts), TaskWeights (Task confirmations), and Unbanked Indicators.)

      

- Test exec podcvotingreport (Rob)
- Check Slovakian User Interface Language (Orbis) to ensure the ?'s have dissapeared
- After F13000 Cutover Height, Block speed has been increased by 4.5% (aiming for 205 blocks per day)

Thank you for your continued support that ultimately helps orphans globally.



« Last Edit: June 12, 2018, 08:04:35 am by Rob A. »


  • togoshigekata
  • Sr. Member

    • 297


    • 17
    • September 01, 2017, 10:21:10 am
    • USA
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #1 on: June 07, 2018, 05:48:52 am »
Awesome! Just to confirm, we will need to run QT (GUI) version of BiblePay for testing?

UPDATE: I jumped the gun, BiblePay v1.1.2.5+ is not on Github yet, so wait for it to be released first: https://github.com/biblepay/biblepay/commits/master

====

TOGO NOTES:
Im going the route of setting up Testnet on a brand new server

1. Create $5 Vultr Ubuntu 16.04 server
https://www.vultr.com/

2. Use Putty to connect to it and Install BiblePay
https://www.reddit.com/r/BiblePay/comments/6ummuj/how_to_mine_biblepay_on_linux/
(Note: Use Swap File to increase RAM before running "sudo make")

Code: [Select]
free #check if swap is 0
dd if=/dev/zero of=/var/swap.img bs=1024k count=1000
mkswap /var/swap.img
swapon /var/swap.img
free #check if swap is 1024

====

3. Install Lubuntu GUI and Reboot
https://www.vultr.com/docs/install-gui-environment-for-ubuntu

Code: [Select]
apt-get update
apt-get install -y lubuntu-core
reboot

4. On Vultr Server Information page click "View Console" button in top right

5. Press Ctrl - Alt + T to open a Terminal

====

**IN PROGRESS**

6. Old Notes on Setting up Hot Testnet Sanctuary
http://forum.biblepay.org/index.php?topic=108.msg1444#msg1444
NOTE: Tesnet uses port 40001 (Prod uses port 40000)

6a. Set BiblePay Wallet to Testnet

Code: [Select]
cd ~/.biblepaycore
vi biblepay.conf
i
testnet=1
:wq

6b. Run BiblePay Daemon to Sync with Testnet Chain

Code: [Select]
cd ../..
cd home/biblepay/src
./biblepayd -daemon
« Last Edit: June 07, 2018, 08:37:01 am by togoshigekata »


  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #2 on: June 08, 2018, 09:58:46 am »
Togo, thanks a lot for the guides.

I just wanted to mention, I was shooting for making this a little easier on everyone who already has a running Prod sanctuary: To possibly save you some money and just run the testnet instance in the same VMS.

I tweaked the OP post with a hint that allows you to run the testnet instance side by side on your prod sanc.
But whatever is easier for all of you by all means.

The need for at least 5 hot sancs in testnet is primarily because we need to test the ability for the wallet to emit both a daily and weekly superblock and verify the chain does not throw any errors, and of course that requires the hot sancs to actually vote.

I'm debugging 1.1.2.5 now, will keep you all posted.



  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #3 on: June 11, 2018, 10:18:18 am »
I'll put up a sanc when you're ready.. will need the funds to start it (testnet)

Thanks!  I'm compiling a windows version now.

It shouldnt be much longer.  I think tonight at the latest, we will be ready for testnet.

Sorry for the delays everyone.



  • MIP
  • Full Member

    • 115


    • 13
    • February 13, 2018, 11:55:52 am
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #4 on: June 12, 2018, 03:09:02 am »
So do we need 1.1.2.5 on both Sanc and windows controller wallet or just in Sanc?

Edit: ok I read again and it's about testing on a hot wallet Sanc.
« Last Edit: June 12, 2018, 03:11:46 am by MIP »


  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #5 on: June 12, 2018, 08:09:48 am »
So do we need 1.1.2.5 on both Sanc and windows controller wallet or just in Sanc?

Edit: ok I read again and it's about testing on a hot wallet Sanc.

You really just need a hot sanctuary running in testnet - if you dont mind voting from a QT hot sanc.  But if you do have a controller testnet QT wallet then it will make testing Bhavanis prod proposals the same as prod. 

In my case Im installing 3 QT testnet hot sancs, running in qt mode, side by side my prod sancs, and Im going to try voting from each hot sanc qt console. 

Note, there was a problem with last nights build, we now need 1.1.2.6.  Im recompiling 1.1.2.6 now (I updated the OP).



  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #6 on: June 12, 2018, 01:16:43 pm »
Alright 1.1.2.6 has been deployed for win + linux.

Testnet is ready to test.



  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #7 on: June 12, 2018, 02:28:33 pm »
Good deal,  will grab it and get setup tonight, any concerns mixing this client with the current live/production?

Would it help if I setup a few mn's? 

I'll run a small mining instance as well,  PODC mapping is the same as production?

As far as mixing prod & testnet, no concerns, otherwise I wouldnt have released it.  Testnet starts with a different switch (see OP post).

Yes, setting up a couple MNs will help.  Im going to shoot for 3.  As long as we get the supermajority to vote like prod, we can then address the test cases.

Yes, PODC is the same in testnet, but you do have to associate your CPID with your wallet in testnet (like prod) otherwise exec getboincinfo wont show anything :).



  • jaapgvk
  • Hero Member

    • 512


    • 20
    • September 01, 2017, 08:02:57 pm
    • Netherlands
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #8 on: June 13, 2018, 07:53:30 am »
Alright, I'm up and running with two wallets.

I have one Sanctuary set-up:

Code: [Select]
14:47:41

masternode status


14:47:41

{
  "vin": "CTxIn(COutPoint(69dfd77724f5b369e19c42fdb9ef5d9416034ac6588da07dfd53db1ae21bfaa4, 1), scriptSig=)",
  "payee": "yYri6dXZEXtN5j6UhTduL1GSEHSDCW1Pif",
  "status": "Masternode successfully started"
}

Code: [Select]
14:52:02

getblockhash 26985


14:52:02

6e3be0e89df723d9bfe9ba9c64404e7643c3baaf667c315f8cc720f77949db57

I will set up the other Sanctuary when I have enough BBP (shouldn't take long).

I don't have any CPID associated with these wallets. Will that be necessary for testnet? 


  • jaapgvk
  • Hero Member

    • 512


    • 20
    • September 01, 2017, 08:02:57 pm
    • Netherlands
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #9 on: June 13, 2018, 11:19:20 am »
to test the PODC payments we need some folks setup and staking


I have one MN up and running will get another  going later today.

Okay, I'm going to set that up too :)

When I try to associate my CPID's I get a 'already in chain' message. Is this because this is still the old testnet? If so, I'll re-associate. I presume it's no problem to have the same CPID on both testnet and prod, right?


  • jaapgvk
  • Hero Member

    • 512


    • 20
    • September 01, 2017, 08:02:57 pm
    • Netherlands
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #10 on: June 13, 2018, 05:07:17 pm »
When I fired test back up it had a few months of history, so yeah most likely a continuation of the old testnet, and per Rob above no conflict having the same CPID in test and prod

2nd sanc up and running.. seems there are a lot of older version sanctuaries left alive for some reason..  curious

Thanks!

Yeah, I noticed a bunch of old-protocol-sanctuaries too...

I've associated my CPID again. Setting up my second Sanctuary right now.


  • togoshigekata
  • Sr. Member

    • 297


    • 17
    • September 01, 2017, 10:21:10 am
    • USA
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #11 on: June 13, 2018, 05:09:39 pm »
updated to v1.1.2.6,, cleaned .dat files, reindexed, 0 connections hmmm, any nodes (IP addresses) I should add?


  • jaapgvk
  • Hero Member

    • 512


    • 20
    • September 01, 2017, 08:02:57 pm
    • Netherlands
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #12 on: June 13, 2018, 05:46:23 pm »
updated to v1.1.2.6,, cleaned .dat files, reindexed, 0 connections hmmm, any nodes (IP addresses) I should add?

You can try these ones:
144.202.88.12
173.165.51.177
73.247.191.58
84.29.208.33


  • Rob A.
  • Administrator

    • 1110


    • 20
    • June 05, 2017, 08:09:04 pm
    • Patmos, Island Of
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #13 on: June 13, 2018, 11:06:24 pm »
updated to v1.1.2.6,, cleaned .dat files, reindexed, 0 connections hmmm, any nodes (IP addresses) I should add?
Sorry, due to the race condition issue today, I had the testnet seed node down (the one compiled in the wallet).

I just brought up 1.1.2.7 lets see if we sync now.



  • togoshigekata
  • Sr. Member

    • 297


    • 17
    • September 01, 2017, 10:21:10 am
    • USA
    more
Re: Testnet June 2018 Mandatory Upgrade Testing Thread
« Reply #14 on: June 14, 2018, 04:00:01 am »
Ok cool!, Updated to 1.1.2.7, cleaned .dat files, reindexed, Im synced now!

./biblepay-cli getblockhash 27834
046ad9e9c7070cbb8a1ebbc68ecef0f3ef3dfc1592663dc5570685085963dd49

===

Could anyone send me tBBP so I can setup a sanctuary? Thanks!
My Testnet tBBP Address: yZyLCtmNkDZmJrCD24MLpuAF2oqZ91hQB9