Bible Pay

Read 21723 times

  • earlzmoade
  • Developer

    • 288


    • 47
    • August 02, 2018, 03:22:01 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #15 on: January 09, 2021, 06:29:04 PM »
Depressing yes, can you please paste your 'getinfo' and your blockhash for 58387? (getblockhash 58387)

Thanks!

Sure thing.
Code: [Select]
01:25:46

getinfo


01:25:46

{
  "version": 1050302,
  "protocolversion": 70762,
  "walletversion": 61000,
  "balance": 606914.88001155,
  "privatesend_balance": 0.00000000,
  "blocks": 58389,
  "timeoffset": 0,
  "connections": 2,
  "proxy": "",
  "difficulty": 3.08252901077341e-005,
  "testnet": true,
  "keypoololdest": 1610190414,
  "keypoolsize": 999,
  "unlocked_until": 0,
  "paytxfee": 0.00000000,
  "relayfee": 0.01000000,
  "errors": ""
}

Code: [Select]
01:27:31

getblockhash 58387


01:27:31

e4860ee360c0fe48397562edc536eb7c0ecc00869ad033caf368144ffc1c381a

Hmm do you think i need to open specific port on router?  It has worked before for me without opening specific port but yeah i dont know.
Joshua 1:9
Have i not commanded you?
Be strong and courageous. Do not be afraid;
do not be discouraged, for the Lord your God
will be with you wherever you go.


  • Rob Andrews
  • Administrator

    • 3862


    • 89
    • June 05, 2017, 08:09:04 PM
    • Patmos, Island Of
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #16 on: January 10, 2021, 08:49:01 AM »
Sure thing.
Code: [Select]
01:25:46

getinfo


01:25:46

{
  "version": 1050302,
  "protocolversion": 70762,
  "walletversion": 61000,
  "balance": 606914.88001155,
  "privatesend_balance": 0.00000000,
  "blocks": 58389,
  "timeoffset": 0,
  "connections": 2,
  "proxy": "",
  "difficulty": 3.08252901077341e-005,
  "testnet": true,
  "keypoololdest": 1610190414,
  "keypoolsize": 999,
  "unlocked_until": 0,
  "paytxfee": 0.00000000,
  "relayfee": 0.01000000,
  "errors": ""
}

Code: [Select]
01:27:31

getblockhash 58387


01:27:31

e4860ee360c0fe48397562edc536eb7c0ecc00869ad033caf368144ffc1c381a

Hmm do you think i need to open specific port on router?  It has worked before for me without opening specific port but yeah i dont know.


AHA, OK thanks man!

The problem is I associated mine back when the code was working, and apparently, I broke something, sorry.

Alright let me fix this particular message type and we will have a release.

Stand by.



  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #17 on: January 10, 2021, 12:27:56 PM »
I successfully registered my user record.

My internal email address is [email protected]

I also sent a test email to [email protected] from the standard MacOS email client.

You can try send me an email to me if you want.


  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #18 on: January 10, 2021, 12:29:14 PM »
I also sent a test email to [email protected] from the standard MacOS email client.

I got this bounce-back email from my provider:

Quote
Delivery has failed to these recipients or groups:

[email protected] ([email protected])
Your message couldn't be delivered. The Domain Name System (DNS) reported that the recipient's domain does not exist.

So maybe I did something wrong


  • Rob Andrews
  • Administrator

    • 3862


    • 89
    • June 05, 2017, 08:09:04 PM
    • Patmos, Island Of
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #19 on: January 10, 2021, 06:26:31 PM »
1.5.3.3 - Mandatory Upgrade for TestNet


- Fix transaction propagation bug for user record
- Fix bug in Chat Decryption

** Note : Windows and Linux are ready.  MIP will have to notify us when MAC is ready **


  • Rob Andrews
  • Administrator

    • 3862


    • 89
    • June 05, 2017, 08:09:04 PM
    • Patmos, Island Of
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #20 on: January 10, 2021, 06:36:26 PM »
I got this bounce-back email from my provider:

So maybe I did something wrong

In the newest version, I have changed the ports to :  30110 for POP3, 30025 for SMTP.

Could you please try re-creating your outlook account with those ports, and critically before you save the record, ensure the From address is "[email protected]" and then click Test settings and ensure the test email goes out of the biblepay client (it should test it and actually send and receive one).
Then also, I believe your outlook client might have tried to send using the internet (and not the biblepay client account), because it was trying to use DNS in the error message.
Please ensure it is sent out of outlook using the Biblepay account (and when you do that it should automatically use the correct From address).

We do plan on doing a DNS connector later, if our market cap goes up, but we don't currently have DNS, so everything is done directly from the pop3 client directly to the biblepay core client (no bytes go over the internet).

Finally I did just send you an e-mail of a blue sky attachment, to your Core address.

Thanks!

PS  Please see the POP3 wiki guide also in the op post just in case.



  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #21 on: January 11, 2021, 02:04:42 AM »
1.5.3.3 - Mandatory Upgrade for TestNet


- Fix transaction propagation bug for user record
- Fix bug in Chat Decryption

** Note : Windows and Linux are ready.  MIP will have to notify us when MAC is ready **

MacOS version is ready


  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #22 on: January 11, 2021, 02:30:18 AM »
I am trying to setup email client using MacOS native one, and using the new ports.

So far I didn't seem to succeed, I will try fiddling here and there (see attached screenshot)


  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #23 on: January 11, 2021, 02:36:35 AM »
Core client seems to be listening

Code: [Select]
netstat -a
Active Internet connections (including servers)
Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)   
tcp4       0      0  *.40001                *.*                    LISTEN     
tcp6       0      0  *.40001                *.*                    LISTEN     
tcp4       0      0  *.30025                *.*                    LISTEN     
tcp4       0      0  *.30110                *.*                    LISTEN

I will check if the issue is at the email client itself


  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #24 on: January 11, 2021, 04:35:36 AM »
I continued with the native MacOS mail client settings, and went to advanced account settings.
I saw there is an "automatically manage connection settings" on so I disabled it and entered the new ports there.

But it seems I still have issues. I can revert back to Outlook and Windows but I think it's interesting to keep on trying here as this seems to be an standard email client so if we make it work here we can be pretty much sure it will work anywhere.

See attached shot of my account advanced setup in case it helps. I will keep on researching meanwhile.





  • MIP
  • Developer

    • 361


    • 47
    • February 13, 2018, 11:55:52 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #25 on: January 11, 2021, 04:43:33 AM »
A bit more research: doing telnet to SMTP and POP3 ports seem to be dropping connection for the former, and working fine for the latter

Code: [Select]
mip$ telnet localhost 30025
Trying ::1...
Connection failed: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.
mips-Mac:~ mip$ telnet localhost 30110
Trying ::1...
Connection failed: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK POP3 server ready <[email protected]>

Normally a telnet to a SMTP server works ok, but don't know if this is an issue here.

Also in the terminal console from where the Core client was launched I see the following messages

Code: [Select]
smtp--shutting down the socket through hangup
SMTP SYSTEM ERROR Already open
smtp--shutting down the socket through hangup
SMTP SYSTEM ERROR Already open
SMTP SYSTEM ERROR Already open
2ASO::Operation canceled
SMTP SYSTEM ERROR Already open


  • earlzmoade
  • Developer

    • 288


    • 47
    • August 02, 2018, 03:22:01 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #26 on: January 11, 2021, 05:53:43 AM »
Got the user record up and running, saw MIP doing the telnet so i did same and got :

Code: [Select]
+OK POP3 server ready <[email protected]>                                                                                                                         
Code: [Select]
220 biblepay - SMTP ready                                                                                                                         
Currently trying to setup the mail side of things.
Joshua 1:9
Have i not commanded you?
Be strong and courageous. Do not be afraid;
do not be discouraged, for the Lord your God
will be with you wherever you go.


  • Rob Andrews
  • Administrator

    • 3862


    • 89
    • June 05, 2017, 08:09:04 PM
    • Patmos, Island Of
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #27 on: January 11, 2021, 09:17:13 AM »
I continued with the native MacOS mail client settings, and went to advanced account settings.
I saw there is an "automatically manage connection settings" on so I disabled it and entered the new ports there.

But it seems I still have issues. I can revert back to Outlook and Windows but I think it's interesting to keep on trying here as this seems to be an standard email client so if we make it work here we can be pretty much sure it will work anywhere.

See attached shot of my account advanced setup in case it helps. I will keep on researching meanwhile.

Cool, well I think you got pretty far with the MAC client.  Looking at your settings I think you entered everything correctly.

So in either pop3 or smtp, there are a certain amount of supported commands, similar to how FTP commands differ over different servers (Microsoft FTP might have RENAME while UNIX has a different variation etc), with the mail, we have some supported base64 auth, others doing cleartext etc.  I think its a matter of having some case statements in there to handle Mac, and or possibly firebird.  Im sure once we find the least common denominator, it will be stable on all 3.

Since I dont have a MAC, I will have to defer to you for some of this unless you would like to try a different client.  When we get to firebird, I think I will be able to jump in and help debug the problem as well (which also could bring it to compliance with mac).

But for now, here is the situation, if you would like to stab it, or try outlook, or try firebird.  (I ran into this situation when working with outlook:  the flow would reach a certain place, then die due to the particular command and its output not being supported).

If you turn on "fDebuggingEmail=true" in the code and recompile and rerun, and be sure to clear the debug.log first, then do your test page setup "test" procedure again (and on a side note, when you restart the client both ports should be listening on telnet - what happened is the dead procedure left the port open, and that will recycle in about 10 minutes which means in normal circumstances it would actually recover later before the mail client makes another poll, but obviously we have to solve the root of the problem anyway), anyway you will start seeing the output of "Pop3::SENT", and "Pop3::RECEIVE" and the same for SMTP:: etc.  What we need to do is see the very last command that got sent and feel free to send it to me (actually the whole log would be better) then we can enhance that particular command.  I might not even be able to work on it without a mac, but I think its beneficial to try in case its easy etc.

Or you can try another client etc, its up to you.



  • Rob Andrews
  • Administrator

    • 3862


    • 89
    • June 05, 2017, 08:09:04 PM
    • Patmos, Island Of
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #28 on: January 11, 2021, 09:21:14 AM »
Got the user record up and running, saw MIP doing the telnet so i did same and got :

Code: [Select]
+OK POP3 server ready <[email protected]>                                                                                                                         
Code: [Select]
220 biblepay - SMTP ready                                                                                                                         
Currently trying to setup the mail side of things.


Sweet.  Looks like you are getting far now, now that you have your "EarlzTnet" username set and pop3 fees checked and it saved! 

So I just sent you an email from outlook through biblepay.  Let me know if you were able to link your mail client to biblepay!




  • earlzmoade
  • Developer

    • 288


    • 47
    • August 02, 2018, 03:22:01 AM
    more
Re: February 2021 Testnet Thread (Tribulation)
« Reply #29 on: January 11, 2021, 10:13:31 AM »
Yeah so i have been trying to get the email app to work for me but not yet.

This is how it looks when i try to link the outlook to  biblepay core.
Not sure why its not connecting,.
Joshua 1:9
Have i not commanded you?
Be strong and courageous. Do not be afraid;
do not be discouraged, for the Lord your God
will be with you wherever you go.